とある工大生の死活日記

とある工大生の死活日記です

トラコン予選突破したぞって話

はじめに

この記事は、whywaita Advent Calendar 2017 - Adventar 19日目の記事です。

 

自己紹介

Twitter→ @katu7414

twitter.com

大阪工業大学 通信方式研究室 4年

・趣味 ゲーム 釣り

・今期見ているアニメ 魔法使いの嫁 キノの旅

mahoyome.jp

・OITLT 元主催者 現エバンジェリスト

・ICTSC9 RFFT 代表兼お茶くみ係です

トラコンって?

ICTSCのことです。(詳細は以下のリンク)

icttoracon.net

whywaitaとの出会いがこの大会だから書いてもいいだろうと思い書くことにしました。

whywaitaとの関係を書くと以下のような感じですね

ICTSC7  自分 運営   whywaita 参加者

ICTSC8  自分 運営   whywaita 運営

ICTSC9  自分 参加者  whywaita 運営

簡単に言えば順番に 敵 味方 敵って感じですね

 

トラコン予選の話

12/16にさくらインターネットNTT-ME杯の参加権をかけたICTSCの予選がありました。

25チーム中実力で突破できるのは10チームなので是非突破したいところでした。

そんな中結果は・・・

 

 

見事 1位でした。

これが言いたかったためにブログ書きました。

点数は900点中795点でした。落とした105点中50点はデータセンター問題だったので無理ですね。データセンターで働いた経験がないので無理です。

あと1位が取れたのはどこかのチームが参加申し込みしなかったからのような気もしますね。

チーム RFFT 代表として本番も頑張ります。

ちなみにRFFTはReluctantly Formed for Tripの略です。

whiwaitaへ

ICTSC9の運営頑張ってくださいね

大阪に来たら飯いこう

本番楽しみにしてます

 

思ったより書くことないのでこのあたりで終わりにします。

ありがとうございました。

以下は予選問題の感想です。

katu7414.hatenablog.com

 

ICTSC9 予選問題 感想と全体的な難易度の話

まずは皆さんお疲れさまでした。

今回は12/16に開催されたICTSC9の予選の感想等を書きます。

感想

疲れた~

初の参加者側でしたが、楽しかったです。

めっちゃ楽しかった

トラコンの予選に向けていろいろ対策してたことが割と当たったのでそれもよかったです。

 

全体的な難易度の話

今回の予選問題は全部で7問でした。(前回は9問)

そのうちネットワークが3問 サーバーが3問 ネットワークと光ファイバー問題が1問みたいな感じでした。

以下自分からみたそれぞれの問題の感想です。(自分はネットワーク問題担当しました)

問1 サーバー問題

うちのチームのサーバー担当が楽しそうに解いてた。

100台のサーバーをどう展開するのかでいろんな解法がありそうで、芸術点とかありそうですね。

たぶんシェル芸するのが正解だと思います。

問2 サーバー問題

サーバーの知識問題だった。

自分はしらない

問3 ネットワーク・光ファイバー系問題

自分も一部解いた。難易度は前回と同じぐらいで、前回と似たような問題が多かった。ここは過去に出場したことがあるチームとそうでないチームで差がつく問題だと思います。ADSLの問題は少し時間かかったな~。

8割取れてたら嬉しい

データセンター問題は前回と同じ(解けなかった)

問4 ネットワーク(知識系)

担当者曰くパケットの気持ちなれば解けるらしいです。

ここはネットワークの知識系問題だな~という感想です。まぁたぶん大きなミスはしてないと思ってる。

問題の系統としてはOSPFの問題でそれぞれのMACアドレスIPアドレスの問題でした。たぶん1時間ぐらいで解いてた。

問5 ネットワーク(config読む系問題)

問題説明
あなたはC社に勤めています。同僚の丘さんはネットワークの管理を任されており、同じサブネットに所属しているはずのPC2とPC4の間で疎通が取れないと連絡が来たそうです。丘さんは解決を諦めあなたに泣きついて来ました。丘さんに原因を教えてあげてください。

みたいな問題でした。

SWが2台あってそれぞれにPCが2台ついてるっていうトポ図でした。

この問題は自分が担当していたのですが、すごく既視感に溢れるトポ図でどこで見たのかを思い出したらすぐ問題が解けました。

cisco独自規格のISLの勉強をしてたときについでにtrunkを勉強しました。その時のネットワークエンジニアとしてにのってるトポ図と状況がほとんど同じでした。以下リンクです。

www.infraexpert.com

なのでたぶんswitchport mode accessではなく、switchport mode trunk にそれぞれ設定し直す必要がある。みたいなこと書いてれば点数貰えると思います。

 

 

問6 ネットワーク(操作系問題)

うちのチームのネットワークのプロが2時間ぐらいで解いてました。

楽しそうだったのでよかったですね

以下本人の感想です。

「楽しい問題をありがとうございました?」

基準満たせば何でもいいやという一言が聞こえましたがたぶん大丈夫でしょう

問7 サーバー(mysql)

担当した人がバイト先でやってることと一緒と言ってたので大丈夫でしょう。

 

だいたいこんな感じでした。問題数が少ない分精神的にも楽でしたね。

難易度の話ですがたぶん第7~8回の予選問題の中では1番簡単だったのかな~と思いました。(少なくともネットワーク側はそうだと思う)

 

具体的な解答や技術的な話は予選突破してたらやります。

 

最後にトラコンOBの方々予選問題作成等お疲れ様でした。

以上です。  寝ます

就職活動のあらゆることを数値化するブログ(過激な内容あり)

はじめに

この記事は、OIT Advent Calendar 2017 - Adventar 14日目の記事です。

 

自己紹介

Twitter→ @katu7414

twitter.com

・通信方式研究室 4年

・趣味 ゲーム 釣り

・今期見ているアニメ 魔法使いの嫁 キノの旅

mahoyome.jp

・OITLT 元主催者 現エバンジェリスト

connpass.com

はじめに

 皆さんモンハンベータ版はやられましたか?

f:id:katu7414:20171213134334j:plain

 自分は最後まで装備裸縛りなどして楽しんでいました。

メイン武器はで生きていきます。

www.capcom.co.jp

以上です。

 本題

注意点 過激な内容が含まれる可能性があります

皆さん就職活動はどうだったでしょうか?

今回は個人的に為になったという観点のみで就職活動の様々なことを学内と学外のイベント含めて書き、点数化します。(100点満点)

よく就活感想ブログなど見かけますが、所詮感想なので理系の皆さんは数値化するほうが良いと考えました。

 

注意点として具体的な企業名は過激なことを書く可能性が非常に高いので

書きません。

----------------------------------------------------------------------------------------------------------------

まず大きな区分として今年の3月までとそれ以降で分けます。

今年の3月まで

  学内イベント

  1. 就職ガイダンス
  2. 履歴書校閲
  3. 学内面接
  4. 代表面接
  5. 学内企業説明会
  6. 学内企業推薦

 それではまず上記の学内イベントから点数化します。

1. 就職ガイダンス (15点)

はっきり言って時間の無駄です。

理由は受ければわかります。

以上です。

 2. 履歴書校閲 (80点)

自分は全て1発で通ったのが自慢です。

書き方の基礎やマナー等を教えてくれるので積極的な利用をお勧めします。

3. 学内面接 (85点)

担当の教授とかと一緒にきてやる面接です。

実はこの面接皆さんの点数つけてます。また担当する企業の人次第では面接の合否を言われます。頑張りましょう。

また担当教員次第で凄い恐怖感や圧迫感を味わえるのでとても良い経験になります。

4. 代表面接 (70点)

学内面接でトップの成績とると就職課から電話がかかってきます。

出ると学部(400人)の前で面接させられるイベントが発生します。さらにその後面接官が実際の特定の企業の面接官ということもあり、軽い交流会へ誘われることになります。

チャンスですね。しっかりアピールしましょう。

5.学内企業説明会 (40点)

個人的にみたい企業が1社だけなのでこの点数です。

20~30社ぐらい来てた気がします。

6.学内企業推薦 (使ってないので点数化なし)

うちの大学が就職強いと言われてる理由の1つとしてこの推薦の多さがあると思うので利用していきましょう。

 

感想  

 就職ガイダンス以外はちゃんとしたイベントが多いので就職活動をする際はきっちりと利用しましょう。

---------------------------------------------------------------------------------------------------------------------

今年3月までの

学外のイベント

ここでは就職活動の為に参加したイベントと結果的に就職活動のためになってしまったものなどを紹介します。

  1. 企業説明会
  2. インターンシップ(1day~3days)
  3. インターンシップ(4days~)
  4. ICTSC
  5. MBSハッカソン
  6. 国際PBL
  7. プライベートマル秘面接

1. 企業説明会 (30点)

これは企業によって当たり外れがある気がしますが、内容どうこうよりも説明会に行ったという結果を重視している企業が多いのではないでしょうか?

時間の無駄になる企業もあります。でも自分が本当に行きたい企業必ずいきましょう。理想はインターンシップのときに説明会をついでに聞いてくることです。

 

2. インターンシップ(1day~3days) (95点)

自分が行った2日間いった企業のインターンシップが最高だったのでこの点数です。

関係者の方々ありがとうございました。

とある東京の企業でしたが、自分たちが見てみたい技術や部門を実際に働いている人から聞けたり交通費も当日支給で飯も豪華でした。

やはり人を大切にしている企業は違うなと思いました。

以上です。

3. インターンシップ(4days~) (85点)

個人的な経験としてこんな企業は個人的に行きたくない向いてないなと感じることができたのが東京のとある企業の3週間のインターンシップでした。

そういう意味では役に立ちました。

大企業のほうがよいという考えはこのインターンシップでなくなりました。

以上です。

4. ICTSC (100点)

ICTSCの共催企業を受けるのなら必ず貴方の力になるでしょう。自分はこれで就活勝ちました。

5. MBSハッカソン (85点)

ハッカソンは協賛企業も多く就職活動になることもあります。

6. 国際PBL (70点)

海外指向である会社にはきっと有利に働いていた。

基本的に話すネタがないときに使っていた。海外が絡んだネタはあると有利

7. プライベートマル秘面接 (90点)

いくつか会社が面接じゃないよって名目で呼ぶあれです。

貴方を呼ぶには理由があります。強気でいきましょう。

成功すればタダ飯、ついでに内定がついてきます。

-------------------------------------------------------------------------------------------------------------------

感想 やはり外部のイベントは内定に直結するのでいいですね

以下グラフです。(青が学内、赤が学外)

f:id:katu7414:20171213232759p:plain

以上で数値化を終わります。

3月以前とその後で分けていくと書いたけど3月以降特に何もしてないので数値化できないことに気づきました。

さて、ここまでブログを呼んでいるあなたはきっと就活生でしょう。

就職活動で一番大切なものはお金です。

就職活動でお金に困ってる人はそういう人を助けるいろんなものがあるので利用してはいかがでしょうか?

supporterz.jp

こういうのもあるので積極的に利用しましょう。

 

最後に一言

来年もOIT Advent Calendarありますよね?

 

もっとこんなものを数値化して欲しいとかグラフ作成したツールをなぜエクセルにしたのか?という意見はTwitterまで

 

第三回OITLT大成功した話

第三回OITLTを主催しました。

詳しくはこちら↓

connpass.com

参加人数は約35人と過去最多人数を更新し、更に参加校数も高専を中心に7校も集まり、レベルの高い大会になりました。また女性参加者も増えうれしかったです。
また今回はベストスピーカー賞とベストネタ賞をを授与しました。ベストスピーカー賞が外部から参加してくれた高専の参加者がベストネタ賞は大阪工業大学のうちの後輩が受賞しました。そしてICTSC8の手元ネットワークの再現も行いました。

f:id:katu7414:20171009180137j:plain

ベストスピーカー賞をとった方のブログです。

chige.hatenablog.com


早くも次回のリベンジを誓う人や次回までに開発して発表するぞという意見を聞いて開催してよかったと感じています。
また大会が盛り上がったことの証明としてハッシュタグoitLTがトレンドにのりました。

f:id:katu7414:20171009174332j:plain

嬉しいですね。
今後もこの活動はやっていきます。関西圏を中心とした学生コミュニティーを盛り上げるために
もしかしたら今後社会人の方に登壇依頼を出すかもしれないですがよければ引き受けていただけるとありがたいです。
また学生向けに企業セミナー等やLTをしたいという依頼も受付中なのでよろしくお願いします。
次回は第3.5回を関西オープンフォーラムにて開催します。
よければご参加ください。

k-of.jp

 では以降大会の様子を写真で載せておきます。

f:id:katu7414:20171009181305j:plain

f:id:katu7414:20171009181305j:plain

f:id:katu7414:20171009181308j:plain

f:id:katu7414:20171009181311j:plain

f:id:katu7414:20171009181315j:plain

f:id:katu7414:20171009181325j:plain

f:id:katu7414:20171009181327j:plain

f:id:katu7414:20171009181333j:plain

f:id:katu7414:20171009181338j:plain

f:id:katu7414:20171009181336j:plain

f:id:katu7414:20171009181340j:plain

f:id:katu7414:20171009181348j:plain

f:id:katu7414:20171009181352j:plain

f:id:katu7414:20171009181353j:plain

f:id:katu7414:20171009181359j:plain

f:id:katu7414:20171009181400j:plain

f:id:katu7414:20171009181406j:plain

f:id:katu7414:20171009181408j:plain

f:id:katu7414:20171009181415j:plain

f:id:katu7414:20171009181418j:plain

f:id:katu7414:20171009181422j:plain

f:id:katu7414:20171009181424j:plain

f:id:katu7414:20171009181427j:plain

f:id:katu7414:20171009181435j:plain

f:id:katu7414:20171009181433j:plain

f:id:katu7414:20171009181439j:plain

f:id:katu7414:20171009181443j:plain

f:id:katu7414:20171009181447j:plain

f:id:katu7414:20171009181454j:plain

f:id:katu7414:20171009181456j:plain

f:id:katu7414:20171009181458j:plain

f:id:katu7414:20171009181504j:plain

f:id:katu7414:20171009181508j:plain

f:id:katu7414:20171009181510j:plain

f:id:katu7414:20171009181520j:plain

f:id:katu7414:20171009181518j:plain

f:id:katu7414:20171009181518j:plain

f:id:katu7414:20171009181525j:plain

f:id:katu7414:20171009181529j:plain

f:id:katu7414:20171009181535j:plain

f:id:katu7414:20171009181540j:plain

f:id:katu7414:20171009181541j:plain

f:id:katu7414:20171009181545j:plain

f:id:katu7414:20171009181546j:plain

f:id:katu7414:20171009181553j:plain

f:id:katu7414:20171009181605j:plain

f:id:katu7414:20171009181611j:plain

f:id:katu7414:20171009181609j:plain

f:id:katu7414:20171009181617j:plain

f:id:katu7414:20171009181233j:plain

ICTSC8 シナリオとOP・ED動画公開

皆さんお元気ですか?

ICTSC8からもう少しで1カ月となります。今回は大会で使用されたシナリオ・OP・EDの公開と作成者達の感想です。

 

シナリオ

シナリオリンク先↓

トラコンのあらすじ - HackMD

(注意)このシナリオは本番のものとは少し異なる点もあります。

感想

シナリオ作成の感想ですが、シナリオ作るのって大変難易度が高いことだと理解できました。初めはがむしゃらにシナリオ作成していたのですが、矛盾だらけと言われて世界観の作成から始まりました。(私は小説を書いた経験などありません。)

 今回このシナリオ作成は3人で、作成しました。シナリオを作成するための世界観作成担当とシナリオ作成担当(私)と編集長がいました。世界観の詳細は上のHackMDの中にリンクあるので、そこから見てください。よって私の仕事は、世界観の設定を読み取りながらシナリオを作成して、編集長に報告して悪いところを指摘してもらうという感じでした。

以下は初めて編集長に報告した時のslackでの会話です。

私 : 編集長出来ました。チェックおねがいします。

編集長: 一通り読んで赤を入れました。
全体的に、まだまだよいものにしていけると思います。文章を見直し、全て書き直すくらいのつもりで改善を重ねていきましょう。

私: そうですね。明日の朝までには修正します。

上記の通り編集長は厳しかったですが理由は明確で、私のシナリオ作成する能力がなかったからです。今振り返ってみると初期の文章は各セリフに意味もなく、繋がりもないし矛盾が多いクソみたいなものでした。成長させてくれた編集長には感謝ですね。

こんな感じで日々シナリオのクオリティを上げるために睡眠時間を削り、作成していました。シナリオ作成中のときは、アニメを見ても俺ならこういう展開するだとか、勝手に想像してインスピレーションを高めていました。

その結果できたものが今大会のシナリオです。

初心者が書いた初めての作品なので暖かい目で見守っていただけるとありがたいです。

以上がシナリオについてでした。

 

 OP動画について

youtu.be

OP動画は主にキャラクター(エイトちゃん)を作成した人と動画を作った人2人で作成しました。作成者の2人ありがとうございました。

 

ED動画について

youtu.be

 ED動画は2人で作成しました。とある会社で動画職人と言われている方が協力してくれるとのことで、こういう動画を作って欲しいという要望を動画職人の方に投げて、細かい調整をこちらでやったという感じでした。そんな感じでしたので、ほとんど私は動画の調整しただけで終わりました。動画職人の方本当にありがとうございました。

動画編集に使用したソフトは、以下のものを使用しました。

www.adobe.com

After Effects使いやすいのでおすすめです。

 

ICTSC8の問題解説 [ストーム制御とVSRX]

ICTSC8の問題解説

ICTSC8から1週間以上が経ちました。皆さんお元気ですか?

今回のブログでは自分が作成した問題の解説と反省をしていきたいと思います。2問作成したので1問ずつ解説します。

 

伝統の国 第一のトラブル

旅の途中、酒場に訪れた。
        
        ドワーフ「お客さん、見ない顔だね。どこから来たんだい?」
        
        エイト「私は始まりの国のはずれよ。この人たちは私が異世界から呼んできたの」
        ドワーフ「ほーう。ここに壊れたスイッチがあって修理する当てを探しているんだが……。まぁおまえらじゃあ解決できないだろうな、ほら帰ってくれ」
        
        そう言い残すとドワーフは、店の奥に消えていった。
        
        エイト「キー! 悔しい。あんたたち絶対直してみせなさい!! 解決して見返してやりましょう」

 

     ## 注意事項
        - 2960B を再起動してはいけない。

        ## 達成すべき事項
        - 7 番ポートをリンクアップをさせ、原因を特定する
        - パスワードを `broken_port?` に変更する。

 という問題です。まずどういう物理トポロジー図であったかというと以下のようになっています。

 

f:id:katu7414:20170905142136j:plain

 2960BのFE0/7でトラブルが発生しました。

トラブルの内容を簡単に説明すると脆弱なパスワード(cisco)を設定していたが、突破されて7番ポートに変えられてしまったという感じです。では解説します。

 

コアの技術

ストーム制御

ストーム制御は、物理NICの不良、ネットワーク構成のミス、DoS攻撃などにより発生するトラフィックストームの影響を制限して制御できる技術です。ストーム制御では、ポートからスイッチングバスを通過するトラフィックをモニターして、パケットがユニキャスト、マルチキャスト、ブロードキャストなのか判別します。次に、スイッチは1秒間に受信した特定のタイプのパケット数をカウントして、事前に定義されたストーム制御レベルのしきい値と、その測定結果を比較します。以下のいずれかを測定方法に使用。

この技術を用いてある程度のパケットが通ればshutdownになるように設定しました。

では具体的なconfigを見てみましょう。

 

ena
  terminal history size 0
  conf t
   
  hostname 2960-B
   
  !KAT
  enable sec cisco
  vtp mode tran
   
  !KAT
  vlan 143
  int fa0/7
  switch access vlan 143
   
  storm-control unicast level 0.0
  storm-control action shutdown
  exit
   
  !internet
  vlan 199
  int range fa0/13 - 24
  switch access vlan 199
  exit
  int fa0/15
  switchport access vlan 199
   
  !892J
  vlan 199
  int range fa0/8
  switch access vlan 199
  exit
  int fa0/8
  switch access vlan 199
  exit
  exit
   
  write memo
   
   
  conf t
  int fa0/7
  no storm-control unicast level 0.0
  no storm-control action shutdown
  exit
  exit

 

 赤文字になっているところが今回のポイントになっているところです。ストーム制御が原因だとすぐにわからないようにnoでコマンドを消しています。またactionをshutdownに変えているのでポートが上がらないようになっています。ポイントとしてはそれぐらいでしょうか?何か質問があれば対応します。

そしてこの問題にはもう一つポイントがあります。それがパスワードを変更することです。`broken_port?`に変更するという指示です。通常ciscoでは `?` を

うつと現在うてるコマンドの候補が出てきます。これを無効化しないとパスワードが設定出来ません。無効化する方法は Ctrl + V です。

解説は以上です。次に講評です。

講評

結果としましては、15チーム中14チームが基準点突破でした。基本的にはパスワードを変更したということ(?を無効化する記述が書かれていること)とポート7が上がっていれば基準点としていました。皆さんがちゃんと解いてくれたみたいでよかったです。

 

荒廃の国 第三のトラブル

トラフィックの問題を解決し、無事に服屋にたどり着くことができた。
        
        エイト「さっそく服を買うわよ……ってお店が開いてないじゃない!」
        
        店の前で大声を出したせいか、中からやつれた顔のエルフが出てきた。
        
        エルフ「すいません。最近盗賊に魔法陣を乗っ取られて、お店のシステムが動かなくなったんです。今は盗賊の対策の真っ最中で、これが終わるまでお店は開けられません。魔法陣を安全に設定したいんですけど……」
        
        エイト「かわいそうに! 私たちが何とかしてあげましょう。安全にsshができればいいのかしらね?」

 

     ## 注意事項
        - ブラウザはfirefoxを推奨する。
        - 指定のURLにアクセスしてクエストを解かなければいけない。

        ## その他
        サーバにデフォルトゲートウェイを設定する際には192.168.16.254/24を使用すること

        ## 達成するべき事項 
        - 管理者ポートとそれ以外のポートの2つへsshができる。
        - どのようにしてsshを可能にしたのか詳細に記載する。

 juniperの問題です。今回vsrxとお借りすることができたため出題することができるようになりました。問題解説を見る前に以下の資料に目を通すことをお勧めします。

www.slideshare.net

コアの技術

Flow-based forwardingモード
packet-based forwardingモード

以上のモード切り替えをするという問題でした。具体的なコマンドは以下の通りです。Flow-based forwardingモードでは、vsrxは元々ファイアウォールのためpingの疎通性の確保が難しいモードです。なのでvsrxをルーターとして扱うためにモードをpacket-based forwardingモードに変えるという問題です。正解するためにはfxp0という管理者ポートとそれ以外のどこかのポートからsshできれば完了です。

delete security
set security forwarding-options family mpls mode packet-based
set security forwarding-options family inet6 mode packet-based
commit
exit
request system reboot
確認するコマンド
show security flow status

1つだけ言わないといけないことがあります。この解答方法はベストアンサーではありません。(大人の方からもできるけどベストアンサーではないよねって言われました。)

これに関しては完全に自分の勉強不足でした。申し訳ないです。

問題解説

具体的にしなければならないことは主に2つです。

  1. インターフェースにアドレスの設定とsshを許可するコマンドをうつ。
  2. モードを変えてリブートする。

以上です。

以下はvsrxを構築していく具体的なコマンドです。問題を解くにあたって必要はないがよく使いそうなコマンドも同時に載せています。

今回はopenstack上にvsrxが乗っている状況になっています。openstackでvsrxをちゃんと使用するためにはいくつかポイントがあります。

モードの移行
cli (junosのコマンド打てるモードへ)
conf (cisco のconf tと同類)

  • pingの疎通性の確保
    コマンド 
    conf
    set interfaces fxp0 unit 0 family inet address 10.0.0.13/24
    set system root-authentication plain-text-password
    set routing-options static route 0.0.0.0/0 next-hop 10.0.0.254
    commit
    exit
    ping 8.8.8.8
    (注意 commitは必ずうつ。コマンドの有効化)
    address 10.0.0.13のところは該当するアドレスで(openstackのやつ)

アドレスはopenstackで使用していたものなので気にしないでください。

上記のコマンドでは管理者ポートにアドレスを付与し、rootでログインするときにパスワードを付与するもので付与しなければcommitするときに注意を受けるのでご注意ください。またstaticでサーバーまでルーティングしています。rootのパスワード設定はこちらでしていたので問題を解くにあたって行う必要はなかったです。

次にsshの許可の設定と新しいユーザーの作成

set system login user katu class super-user
set system login user katu authentication plain-text-password
set system services ssh sshの有効化のコマンド
set system services ssh root-login allow

これでkatuというユーザーを作り、またsshの許可をしています。

次にvsrxをルーターとして使用するためのコマンド
delete security
set security forwarding-options family mpls mode packet-based
set security forwarding-options family inet6 mode packet-based
commit
exit
request system reboot
確認するコマンド
show security flow status

ホスト名の設定
set system host-name vSRX-1

管理者ポート以外のポートからsshする方法

set interfaces ge-0/0/0 unit 0 family inet address 10.0.0.13/24

だいたいこんな感じです。問題講評をしたいところでしたが、解答数が0だったので代わりに構築中に起きた様々なトラブルについて書きます。

 

構築中のトラブル

まずopenstackの上にvsrxをのせることになったのですがopenstackもvsrxも触ったことがなかったので、1からの構築になりました。

f:id:katu7414:20170906191213p:plain

インスタンス作成をすると上の画像のような感じになりました。

カーネルパニックが起きている状態です。理由としましてはメモリを4GB未満でインスタンス作成をしていたからです。必ず4GB以上でやりましょう。

次にsshで疎通できるようにしようと思いました。しかしvsrxでどう設定してもできませんでした。状態としてはpingは通るがsshできないという感じです。これは別の運営委員の方が原因を特定してくれました。

SSHの接続は確立してたけど鍵交換のところで止まっていたので,おそらく原因はMTU
vSRXのFloating IPに 1500byteでpingうつと落ちる.1472byteが限界
VXLANのオーバーヘッド分だと思うんだけど,MTUを調整しないといけない

という返事をいただきました。というわけでMTUを調整しようと思い管理者ポートのMTUを1450にしようとしましたが管理者ポートはMTUを変えることはできないので他のポートからsshしようとして2つのFlow-based forwardingモードpacket-based forwardingモードを知りました。そしてge-0/0/0からsshできるようにして無事に出来ました。よって検証環境では管理者ポートではsshできずに他のポートからしかsshできないという謎の環境が出来上がりました。

次にopenstackがvsrxの新しく作成したポートを認識しないという問題が発生しました。結果から言えばおそらくですが原因はopenstackのポートフィルターが働いていたのが原因です。これらを考慮して次のような手順で構築しました。

  • openstackのインスタンスを建てる
  • インターフェースは2つ以上必ず追加する。
  • 2つ目は外部に疎通性があるようにする(sshするため)
  • Floating IPの付与
  • インスタンス起動
  • ge-0/0/0にアドレスを追加
  • 外部への疎通性の確認
  • sshの許可のコマンド
  • ge-0/0/0 のmtuを1450にする
  • sshできる
    注意点 この手順通りでなければならない。また1つ目のインターフェースは管理インターフェースfxp0に付与されるので必ず2つめのインターフェースに疎通性の確保できるアドレスを付与すること。そしてopenstack側にNICを追加を認識させたいときはインスタンスを停止させてから起動させる。

vsrxにはアドレスを付与する順序があるらしくこの手順でなければできませんでした。

このあたりで時間がなくなり、検証は終了しました。この構築過程を問題にしようと思い今回のような問題になりました。

感想

今回出題出来なかったですがciscoとvsrxでIPsecを貼る問題を出そうとあがいていたのですが時間がなく出題できませんでした。マルチベンダー問題を期待していた方申し訳ないです。

全体の感想です。今回ネットワーク系の問題の数が少ないと感じた方がいたと思います。その点に関しては申し訳ないです。運営委員にネットワーク系の問題を作成する人が減っており、問題数が減ってしまいました。

問題の質問やもっといい解答を知っているという方は自分のツイッターまでご連絡いただけるとありがたいです。

twitter.com

また10/7にネットワーク系の問題を中心に問題解説をするLT大会を開催します。よければご参加ください。

connpass.com

以上です。ありがとうございました。

運営委員体験日記 ~小説家になりました

ICTSC8 運営委員としての感想

 皆さんお元気ですか?

 ICTSC8の運営委員をやらせていただいた嶋です。

 もっとはやく書きたいという気持ちがありましたが体調不良のため延期に延期を重ねておりました。

 ではさっそく今回の振り返りをしていきたいと思います。注意事項として自分の作成した問題については別に書くのでここでは書きません。あくまでも運営委員としての振り返りを書くだけです。

 

 今回の自分の役割

 今回は初めての役職をもってやりました。副リーダーというICTSCで1番何しているのかよくわかってない役職をしました。結果どんな仕事をしたかというとすべての仕事に少しずつ関わって少しずつ仕事をしました。ICTSCの運営委員というのはできる人ができることをするだけの組織なので誰かが全体の状況を把握しなければなりません。そこは把握していけたらな~という気持ちがありました。その結果今回は小説家になりました。よくわからないですね。そんな感じで今回自分が担当した仕事は以下の通りです。

  • 手元ネットワークの設計やconfigを流し込むこと
  • 問題文のシナリオの土台の作成
  • 司会
  • 自分の問題作成 (今回は2問)

 今大会の感想

 私はICTSC7から運営委員をやらせていただいていますが、前回大会は仕事量も少なく楽しい大会でした。今回は準備期間が短いこともあり前回と比べると睡眠時間が半分以下になり仕事量も倍でした。洗濯する時間を見つけ出すのが1番苦労した点ですね。

 さて今大会の問題の難易度はいかがだったでしょうか?ネットワーク系の問題の難易度は前回より上げたつもりです。前回大会でネットワーク系の問題で点数を稼いでいるチームが多かったため難易度をあげました。またjunosの問題も出ました。ICTSCにもマルチベンダーの時代が到来しつつありますね。よいことだと思います。私自身参加者側になって今回のネットワーク系の問題を全て解けたかと言われれば少し怪しいです。しかし良問をそろえたつもりなので皆さんの勉強になれば幸いです。

 

 小説(シナリオの話)

 今回のICTSCの世界観どうだったでしょうか?シナリオの詳細は後日(9月中)に公開出来ると思います。OPとEDの動画セットで公開出来ると思います。シナリオの完成度はそこまで高いものではないですが是非読んでみてください。

 

 今後のICTSC

 今後ICTSCがこうなっていけばいいな~という個人的見解です。個人的に感じていることが本大会は問題を解くだけとかして解説がブログだけなのでいつか問題作成者が問題解説をする勉強会を開けばいいのにな~と感じています。そうすれば参加者の皆さんも、もっと具体的にこう勉強しようとか運営委員と参加者の間で繋がりも出来ますしいいんじゃないかな~と思います。宣伝にはなりますがとりあえず大阪で問題解説を含めたLT大会をやります。是非ご参加ください。

connpass.com

 次回大会について

 次回は参加者側で参加しようかな?と考えています(何かあれば運営委員やるかもしれないけど)。優勝したら副賞もついてくるらしいので頑張りたいですね。違う大学の人と組みたいのですが誰に言えば許可でますかね?偉い人許可ください。お願いします。